Back to overview
Degraded

Login is unavailable

Oct 20 at 10:22am CEST
Affected services
app.cradle.bio

Resolved
Oct 20 at 12:08pm CEST

The issues have been resolved and users can login to Cradle again.

Updated
Oct 20 at 11:31am CEST

The upstream provider continues to be impacted by the AWS incident. We continue to be in touch with them and will provide updates here.

Created
Oct 20 at 10:22am CEST

An upstream provider is experiencing issues resulting in errors when logging into Cradle. We are in contact with the provider to restore functionality.